
OsoSoft's Fonter 5.0
=====================

INTRODUCTION
============

Windows 3.x lets you use fonts quickly and easily, both on
the screen and in your printed documents. Using Windows
3.1's TrueType fonts, or fonts automatically scaled by
programs like Adobe Type Manger, Bitstream FaceLift, and
others, you can have access to thousands of typefaces, all
of which will work in any Windows program.

But there's a problem. It's often difficult to choose just
the right font for the job. That's where Fonter comes in. It
lets you view any Windows font on the screen, in several
ways. Even better, Fonter lets you create printed lists of
all your fonts, with a text sample of each font. You can
also print sample sheets showing your font in all of its
variations, and a character set chart which will help you
discover just what characters are in every font.

Windows uses the ANSI character set, which not only includes
normal keyboard characters, but foreign language and
symbolic characters as well. Still, all fonts don't contain
exactly the same characters. You need a way to find out if
the characters you need are in the font you want to use.
Fonter lets you do that quickly.

Finally, dingbat and symbol fonts contain special characters
for enhancing your documents. But they aren't regular
keyboard characters, so it's hard to know what character
you'll get when you press a key. Again, Fonter comes to the
rescue, letting you print sheets showing every special
character, along with the key to press to display that
character.

SYSTEM REQUIREMENTS
===================

Fonter requires a 386SX or better PC, with a minimum of 2 MB
of memory. You'll also need a printer with a Windows driver
that takes full advantage of that printer's capabilities.

LICENSE INFORMATION
===================

This is the shareware version of FONTER. You may use it only 
for a 30-day trial period, to evaluate its usefulness. After 
that time you must register your copy. Registration costs 
just $15, so there's no real reason not to register.

There are three ways to Register:

1. Send a check, or money order, drawn on a US bank, for $15 
to:



OsoSoft
1472 Sixth Street
Los Osos, CA  93402

2. To order with a credit card, call the Public (software) 
Library at (800) 242-4775. Tell them you want to register 
FONTER. A $4 shipping and handling fee will be added if you 
order through this number. NOTE: THIS NUMBER IS FOR ORDERS ONLY!!!

3. After August 1, 1992, you can register on CompuServe. Give 
the command, GO SWREG. The Program name is FONTER. 
Registration fees will be charged to your CIS account.

Registered users will receive the latest Registered Version 
on disk, and will be entitled to full voice and Email support.

SYSTEM LIMITATIONS
==================

Font Scaling Software
Fonter works with TrueType, Adobe Type Manager, Bitstream
Facelift, and SuperPrint 2.0 scalable fonts. Other font-
scaling software is untested.

Drop to DOS
Do not drop to DOS or run a DOS program while Fonter is
minimized! An incompatibility in Microsoft Visual Basic can
cause Windows to become unstable if you do this.

Defective Fonts
Some TrueType and Adobe PostScript fonts have defects. This
can cause Fonter or other Windows software to crash. To spot
these fonts, and if you have problems with Fonter or other
Windows software, view each font in Fonter's window. If you
have a problem, delete that font. For more information, see
the Troubleshooting section at the end of this manual.

INSTALLATION
============

To install Fonter, follow these steps:

1. Create a directory on your hard disk for the Fonter
files, using the DOS CD command or the Windows File Manager.
Example: C:\FONTER

2. Copy all the files from the Fonter distribution disk or
the FONTER.ZIP file into that directory.

NOTE: If you're upgrading an existing version of Fonter,
simply copy all files into your current Fonter directory.
You can skip the remaining steps.

3. Copy the VBRUN100.DLL file from your distribution disk
into your main Windows directory. If you do not have a copy



of this file, which is not shipped with the ZIP version, you
may download VBRUN100.ZIP from the OsoSoft BBS. (805) 528-
3753. This file is the Microsoft Visual Basic runtime
library. You need only one copy of the file for all your
Visual Basic programs, which is why the file is not included
with the .ZIP version of this program.

4. In the Windows Program Manager, click inside the program
group window where you want the Fonter icon. Then click the
File//New command and click OK in the next dialog box.

5. Type in the information for FONTER in the next dialog
box. Include the complete path for the program in the
Command Line field. If you're using Windows 3.1, also type
the path to the Fonter directory in the Working Directory
field. Then, click OK. The Fonter icon will appear in your
selected program group. If you do not see it, scroll the
group window to find the icon, then move it to a new
location.

That completes installation of Fonter.

RUNNING FONTER
==============

To start Fonter, double-click its icon in the Program
Manager. The first time you run the program, it will create
a list of your fonts and save the list in a file. This
process can take a minute or two. You'll see a window
telling you what's going on. On subsequent loading, Fonter
will use its own font list, letting you know if there are
changes in your fonts and offering to create a new list at
your option.

USING FONTER
============

The Fonter Window

Once Fonter starts, you'll see its main window. Along with
the normal Windows menu, at the top left of the screen,
you'll see the Font Sample window, which displays a sample
of the currently-selected font.

To the right, you see the list of all your fonts. Below that
are three buttons, with a list of selected fonts below the
buttons.

To the left of the Selected Fonts window are a number of
option check boxes and other Fonter options.

Viewing a Font Sample

To see a brief alphanumeric sample of any font, just click
on the name of the font in the Main Font List window. Use
the scroll bars on that window to view more font names.



HINT: Click on a font, then type the first letter of your
desired font for faster scrolling.

Selecting a Font

Many Fonter operations use a list of selected fonts, shown
in the Selected Fonts window at the bottom left of the
Fonter window.

To add a font to the Selected Fonts list, double-click on
the desired font name in the Main Font List. Or you can
click the [Add] button to add the currently-highlighted
font.

To delete a selected font from the list, click on the font
name in the Selected fonts window, then click the [Remove]
button.

To clear the selected font list, click the [Clear All]
button.

Updating Your Font List

If you add or delete fonts from Windows, or change printers,
you'll need to update your font list. When you start Fonter,
it checks its own list against the list of actual Windows
fonts. If it finds any discrepancies, it will ask you if you
want to update the list. You should do so. If you want, you
can also update the list with the "Re-list Fonts" command in
the "File" menu.

Setting Font Options

You can alter many aspects of Fonter's display by selecting
a number of options. All options are at the bottom left of
the Fonter Window.

Font Size
To change the size of a font sample, click the arrow on the
Font Size drop-down list, then click the size you want. You
can scroll down the list to see more sizes. The font size
you select will display in the Font Sample Window and will
be the size you see in printed font lists.

You can also type a font size larger than 36 points directly
in the Font Size window. Just click in the window, type the
font size, then press <Enter>.

NOTE: Font lists will print in a maximum size
of 36 points, regardless of the size you enter.

Bold and Italic
To display Bold, Italic, or Bold Italic samples, click the
appropriate check box. These options also function when
printing a font list.



Custom Text
To View specific text in the Font Sample window, type it in
the sample text box at the bottom left of the main screen.
Just click inside the box, then type your text. You can use
the normal <Home> and <End> keys to scroll the text if you
type more than is visible in the box.

Once you type the text, click the Show Custom Sample box.
Your custom text will display in the Font Sample window. If
this box is checked, that text will also appear in the Font
List printouts.

Text Samples
You can also type directly in the Font Sample window. To do
this, click in the window and type away. You can use normal
Windows text selection tools while in this window to delete
existing text. The Cut and Paste tools in the "Edit" menu
also work here, as do all Windows cut and paste shortcut
keys.

Displaying ANSI Codes
You can display ANSI codes for all characters in the Font
Sample window. To do this, give the "Display ANSI Codes"
command in the "Options" Menu. It takes a few moments to
load all the codes, and the Font Sample window will
disappear while the codes are loaded. To view more codes,
use the scroll bar on the window.

NOTE: Each time you change fonts, Fonter has to load all the
characters. For faster access to ANSI Codes see the "Full
Screen" section below.

Selecting a Text Font
Fonter uses Courier as the descriptive text font in
printouts. This is because some fonts don't have the
alphabetical characters needed to print descriptions. To
change this font to one of your choice, first click on the
font name in the Main Font List window, then give the "Make
Current Font the Text Font" command in the "Options" menu.
Your choice will show in the Text Font: line on the screen.

FULL SCREEN DISPLAY
===================

Fonter offers a full screen display of characters for any
font. To view this, click the [Full Screen] button. You'll
see a list of the keyboard characters, with ANSI codes.

Extended ANSI Characters
To view codes for foreign language and symbolic characters,
click the [Extended Characters] button on the full-screen
display.

To return to the normal, keyboard character display, click



the [Normal Character] button.

Zoom
To view an enlarged character set, click the [Zoom] button
on the full-screen display. Character size will double.

To view an even larger sample, highlight a character by
dragging the mouse cursor over it while holding down the
left mouse button. Then click the [Zoom] button. You'll see
a 200 point sample of your character.

To return to the normal full-screen view, click the [Normal
Size] button.

To return to the main Fonter Window, click the [Return]
button in the full-screen display.

As with the sample window, you can use the Full-Screen
display's Edit menu to cut and paste selected characters.
This feature uses the normal Windows Clipboard, so you can
copy a character into the clipboard, then switch to another
application and paste that character into that application.

PRINTING WITH FONTER
====================

While Fonter's on-screen display is useful, the program's
real function is to print out lists and samples of your
fonts. There are a number of ways to print your fonts. All
printing commands are in Fonter's "File" menu.

All Fonter printouts have a 1.25" left margin. If you print
on 3-hole binder paper, it's easy to put your font lists and
samples into a binder for quick reference.

Printer Information

Fonter always prints to the default Windows printer. Once
Fonter is running, you cannot change printers. However, you
can change printers anytime Fonter is not running. Use the
Windows Control Panel and the Printers icon to switch to
another printer. Be sure to make your printer choice the
Default printer by double-clicking on it in Windows 3.1 or
selecting it as the default in Windows 3.0.

NOTE: If you change printers, you'll need to update your
font list inside Fonter. Just click [Yes] when Fonter
proposes a font list update.

Printing Font Lists

List All Fonts
To print a list of all fonts installed in Windows for your
current printer, give the "Print List (All)" command. The
list will contain the name of each font, along with a text



sample for that font. If you have entered custom text and
checked the "Show Custom Sample" box, that text will print
following the font name in the list.

Font lists print in the font size selected in the Font Size
drop-down list. If you've selected a font size larger than
36 points, Fonter will revert to 36 points for the list.
Font lists also use the Bold or Italic attributes you select
with the check boxes at the bottom left of the main Fonter
window.

NOTE: Some internal printer fonts have a fixed size. These
fonts will print in their default size, although they will
display on the screen in other sizes.

NOTE: Printing a complete font list can take several
minutes. Please be patient while printing takes place.

List Some Fonts
To print a list of just the fonts in your Selected Fonts
window, give the "Print List (Selected)" command. This will
print a list of only those fonts in your selected font list.
All comments above apply to this list as well.

Printing Font Samples
Fonter can create two separate font sample sheets. One is a
sheet displaying your selected font in several sizes from 3
to 60 points. This sample also displays Bold, Italic, Bold
Italic and Underlined sample text, plus a complete list of
the font's characters, divided into logical groups. It's a
great way to view any font in a variety of styles.

The second sheet contains an grid-like chart of every
character available in the font. This chart lets you see the
ANSI code for any character at a glance. You'll also see the
normal Windows keyboard character or extended ANSI
character. On symbolic or dingbat fonts, this character is a
reference for which key to push to access any character.

You can print either sheet, or both. Simply check the
appropriate box in the lower left corner of the Fonter Main
window. The "Print Grid" box controls the ANSI grid, while
the "Print Sample" box controls the sample sheet. Be sure to
select the appropriate boxes before printing. The default is
to print both sample sheets.

Single Font Sample
To print samples of the currently-selected font in the Main
Font List window, give the "Print Sample (Current)" command
in the "File" menu.

Multiple Font Samples
To print samples of more than one font, first add the fonts
to the Selected Fonts window, then give the "Print Samples
(Selected) command.



NOTE: You can abort a multiple font sample printing job.
Just click Fonter's [Exit] button with the hourglass cursor.
Fonter will cease printing after finishing with the current
font.

Printing Font Books

Fonter offers a way to automate printing to create font
books, which contain both font lists and font sample sheets.
Fonter first prints a list, as in the Font List commands,
then prints samples for each font.

Sample sheets print in the same way as described above. You
can elect to print one or both of the sample sheets. When
you print a font book, though, the font list size is always
12 points.

NOTE: Printing a font book for all fonts can take as long as
8 hours! Plan to print your font book at night, or when you
don't need your computer or printer.

Aborting Font Book Printing
You can always abort font book printing. Just click Fonter's
[Exit] button with the hourglass pointer. Printing will
cease following the current font.

WARNING: Check your printer's paper capacity. You'll be
printing up to two pages for each font. If your printer
doesn't hold enough paper, the process will abort until you
add paper. If you have too many fonts to print a complete
font book, do this instead:

Print a complete font list, then add fonts to the Selected
Fonts list box as described above. Use the "Print Samples
(Selected)" command to print these in groups small enough
for your printer's paper tray.

DOT MATRIX USERS:  Printing font samples is a very slow
process, so plan accordingly.

Complete Font Book
To print a font book for all fonts installed, give the
"Print Book (All Fonts)" command in the "File Menu".

Partial Font Book
To print a font book of just some fonts, first add the fonts
you want to print to the Selected Fonts list, then give the
"Print Book (Selected)" command. This is a great way to
print custom samples for customers if you're a graphic
designer or print shop.

GETTING HELP
============



Help with Fonter
Fonter offers a help system to answer your questions. To use
this system, give the "Fonter Help" command in the "Help"
menu, or press <F1> at any time.

You'll see a new window on the screen. On the left is a
Topic Index. On the right is the Help information. To view
help on a topic, simply click on that topic in the Topic
Index. To view more topics, use the Topic Index scroll bar.

You can also scroll through the Help information window with
its scroll bar.

Returning to Fonter
Click the [Exit] button or the "Return to Program" command.

About Fonter
To view information about Fonter and to find the OsoSoft
support access numbers, click the "About Fonter" command in
the "Help" menu.

OsoSoft Program Information

OsoSoft offers a number of other programs which may be of
interest to you. To view information on other OsoSoft
products, or to order, give the "OsoSoft Program Info"
command in the "Help" menu.

You'll see an order form for OsoSoft products. To learn more
about any product listed, click the [Info] button next to
that product's listing.

To order, simple type the number of copies for each product
in the box next to that product's name. The rest is
automatic. Be sure to click the appropriate disk size
option, then click the [Print] button to print the form.

To return to Fonter without printing, click the [Cancel]
button.

SUPPORT
=======

If you are an unregistered user of Fonter, do not call 
OsoSoft on its voice number. No phone support is available 
for unregistered users.

Only registered users of Fonter or any other OsoSoft product
are entitled to support by telephone, FAX or EMail. You may
contact OsoSoft for very limited support of this unregistered 
copy at:

OsoSoft
1472 Sixth Street
Los Osos, CA  93402
BBS: (805) 528-3753



CompuServe ID: 71571,222

When You Need Support

Before you call or contact OsoSoft for support, please have
this information available:

Computer Type
Printer Brand and Model Name
Fonter Version Number (from "About" menu)
Amount of RAM in your computer
Amount of RAM in your printer

The OsoSoft BBS

You'll always find the latest versions of OsoSoft programs
on the OsoSoft BBS, along with other helpful programs and
other information. To call at speeds from 300-2400 bps, set
your communications parameters to 8 bits, No parity, and 1
Stop bit. You'll find the BBS easy to use, and it's the best
way to get support. Just leave a message for the SysOp.

If you'd like to try any OsoSoft product, you can download
the current shareware version of the program from the BBS.

UPGRADES
========

Registered users of Fonter can obtain upgrades on the
OsoSoft BBS. When you call, tell me that you're a registered
Fonter user, and I'll give you access to upgrades. This is
by far the best way to upgrade your copy.

If you don't use BBSes, you may upgrade at any time for a
$10 handling fee. I will send postcard notification of major
upgrades to the program. I will not announce minor upgrades,
but you can always call and check.

TROUBLESHOOTING
===============

Defective Fonts

Some fonts, particularly public domain and shareware fonts
which have been converted from another format, can cause
problems in Windows programs. Fortunately, there's a way to
spot these defective fonts in Fonter. Just follow these
steps:

1. Start Fonter, then give the "Display ANSI Codes" command
in the "Options" menu.

2. Click on each font you have installed, in turn. When you
reach a defective font, Windows will generate an error,
probably a General Protection Fault (GPF). When that



happens, exit Fonter as gracefully as possible, under the
circumstances, then delete that font, using the Windows
Control Panel or your font scaling software's tools.

3. Repeat the process until you see no more problems.

You can also spot defective fonts in a Fonter font list
printout. A bad font will not print, and will corrupt the
printouts for later fonts. Again, the answer is to delete
the offending font. BUT, delete only the first font that
doesn't print properly, then print a new list.

OTHER PROBLEMS
==============

PROBLEM: Fonter just won't run at all.
SOLUTION: Check your installation. Make sure VBRUN100.DLL is
available in the Windows directory.

PROBLEM: Fonter crashes constantly
SOLUTION 1: Check your Windows setup. Disable any programs
running in the background then try again. If it runs
correctly, add the background programs one at a time until
you have a problem.
SOLUTION 2: If you're using a memory manager like QEMM, you
may need to EXCLUDE certain portions of memory. Make a note
of any memory block information you see if you get a General
Protection Fault Error, and use that as a guide to areas to
EXCLUDE.
SOLUTION 3: Make sure your Video and Printer drivers are
current and the correct ones for your version of Windows.
Windows 3.0 drivers will not work reliably in Windows 3.1.
SOLUTION 4: As a last resort, try running Windows with no
addons at all. This may require a fresh installation. If
you're having problems with Windows generally and with other
Windows programs, this is probably your best solution.

PROBLEM: Some fonts do not print in the size I expected.
SOLUTION: Fixed-size internal printer fonts can only print
in their default size, even if they display on the screen in
other sizes.

PROBLEM: In the ZOOM view, some characters are cut off.
SOLUTION: For some very wide characters, Windows cannot
display the entire character correctly. Printing will be
correct.

PROBLEM: In font lists, some text goes right off the edge of
the page.
SOLUTION: Ignore this. Fonter prints as much of its sample
text as it can. You can also create a shorter, custom text
sample for the printout (See above), or choose a smaller
font size.

PROBLEM: I pasted a dingbat symbol into my word processor,
but I didn't see what I expected to.



SOLUTION: The Windows Clipboard only copies the character
code into your other application. You must change fonts
manually in that application to get the correct character.

▯


